読者サポート

Androidプログラミングバイブル SDK4/3/2対応

著者:
布留川 英一
定価:
3,218円(本体価格 2,980円)
発売日:
2011年12月21日
Androidプログラミングバイブル SDK4/3/2対応

ダウンロード

本書で解説したサンプルプログラムを以下より、ダウンロードできます。なお、使用方法などに関しては、必ず本文の該当箇所をご確認ください。

(約6.2MB。zip形式で圧縮してありますので、ダウンロード後解凍してください)

正誤情報

以下の補足情報もご参照ください。

補足情報

2012年6月14日
「4-9 フラグメント」のAndroidManifest.xml
AndroidManifest.xmlには、以下の<activity>を追加する必要があります。
<activity
android:label="DetailActivity"
android:name=".DetailActivity">
</activity>

「9-3 Twitterクライアント」での認証エラー
Twitterの認証時にエラーになる時は、以下の原因が考えられます。
・Android端末の開発者オプションで「アクティビティを保持しない」チェックしていると動かない。
・時計が正しくないと動かない。
・Eclipseでライブラリのパスを通す際、「順序およびエクスポート」で該当ライブラリにチェック入れないと動かない。

2013年3月2日
「9-3 Twitterクライアント」が動作しない1
Twitter API 1.1のリリースに伴い、API 1.0を使ったプログラムは動作しないため、API 1.1に対応した修正版を以下よりダウンロードしてください。

TwitterClient(API 1.1対応版)

2013年3月21日
「9-3 Twitterクライアント」が動作しない2
Android 2.3ではshouldOverrideUrlLoading()が呼ばれないことがあり、ソースコードのshouldOverrideUrlLoading()をonLoadResource()に変更して、サイトページのURLのみ判定するため「callback+"?"」と比較するように修正する必要がある。
詳しくは、修正版を以下よりダウンロードして、ソースコードのonLoadResource()メソッドをご覧ください。

TwitterClient(Android 2.3対応版)

サポートページを探す

タイトル、著者名、ISBNなどで検索してください。

※書籍によっては、サポートページがない場合もございます。ご了承ください。

書籍についてのお問い合わせ

各サポートページで問題が解決しない場合は、お問い合わせページよりご連絡ください。

お問い合わせ